HACHA v3.5

DrSoftware@hacha.org
Making life easier... One program at a time
Vous en rêvez... Je le fais
Macht das Leben leichter... clevere Lösungen mit einfachen Programmen

Was ist Hacha?

Hacha (sprich: "Atscha", Axt auf Spanisch) ermöglicht es, beliebige Dateien in Teile von bis zu 0,01 MB zu zerlegen!
Danach können die Teile auf Standard 3½"-Disketten oder andere Medien kopiert werden, um sie zu tranportieren oder übers Internet zu verschicken. Die Teile können zu jeder Zeit auf jedem anderen Rechner wieder zusammengefügt werden, wenn Hacha dort installiert ist.

Hacha 3.5 ist schnell und einfach zu bedienen. Mit dieser Version kann man 600 MB-Dateien in unter 75 Sekunden teilen, außerdem können Dateien von über 2 Gb. problemlos zerlegt werden. Man braucht nur die zu teilende Datei auszuwählen (auch auf CD) und muß dann noch ein Zielverzeichnis für die Teile angeben. Man kann bei Bedarf die Namen der Teile eingeben.

Hacha 3.5 unterstützt Prüfsummen (CRC, Cyclic Redundancy Check), mit denen die Richtigkeit der Dateien geprüft wird. Dann wird Dir mitgeteilt, ob die Zieldatei exakt mit der Quelldatei übereinstimmt oder nicht. Dies ist besonders wichtig bei Dateien, die übers Internet übertragen wurden. Hierbei kommt es schon einmal zu Fehlern.

Anmerkung: Hacha's CRC wird nur in diesem Programm so benutzt und kann nicht anderweitig verwendet werden. Dafür ist es aber auch eines der schnellsten überhaupt.

Hacha 3.5 ist abwärtskompatibel, das heißt, es können Dateien zusammengefügt werden, die mit älteren Versionen geteilt wurden, umgekehrt jedoch nicht.

Systemvoraussetzungen

Hacha 3.5 arbeitet unter folgenden Betriebssystemen: OS/2, Windows 95, Windows 98, Windows Me, Windows XP.

Weiterhin sollten Sie ein Mensch, kompatibel oder geklont sein und genügend Speicher haben, um sich daran zu erinnern und Mahatma "Dr. Software" eine kleine Mail für dieses fantastische Programm schicken.

Außerdem verwendet Hacha 3.5 viele Grafiken und ist dennoch nur 85 kB groß, einschließlich dieser Hilfe.

Das Hauptfenster:

Das Hauptfenster enthält nur 3 Optionen:
  • Teilen um Dateien zu zerlegen.
  • Kleben um geteilte Dateien wieder zusammenzufügen.
  • Sprache & Hilfe rechter Mausklick auf das Logo.

Einfacher geht's nicht!

Teilen

  1. Drücke "Teilen". Das Standard-Fenster zum Öffnen von Dateien wird angezeigt:

  2. Wähle die Datei, die geteilt werden soll, dann drücke "Öffnen". Danach wird das Fenster "Teilen als" angezeigt. Der gewählte Dateiname erscheint im oberen Textfeld:

  3. Im Feld "Größe" kann die Größe der Teildateien angegeben werden. Vorgabe ist 1,38 MB (für 3½"-Disketten) aber man kann jede beliebige Größe eingeben. Markiere hierfür den zweiten Auswahlknopf und gebe die gewünschte Größe in das kleine Feld daneben ein. Bedenke, daß die kleinste Größe 0,01 MB beträgt!

  4. Wähle dann eine oder mehrere der folgenden Optionen:

    • Quell- = Zielpfad: Mit dieser Option werden die Teildateien in demselben Verzeichnis erstellt wie die Quelldatei. (Voraussetzung ist natürlich, daß in das Verzeichnis geschrieben werden kann, sonst erhälst Du eine Fehlermeldung!) Falls diese Option nicht gewählt ist, wirst Du nach einem Zielpfad für die Teildateien gefragt.

    • Quelldatei löschen: Mit dieser Option wird die Quelldatei nach dem Teilen gelöscht. Einige Teletubbies haben diese Option schon mit CD-ROMs probiert ]:( Wähle diese Option nicht, wenn Du die Quelldatei behalten willst.

    • CRC erzeugen: Wähle diese Option, um beim Teilen eine Prüfsumme zu erstellen. Diese wird dann beim Zusammenfügen der Dateien verwendet, um zu prüfen, ob die erstellte Datei exakt der ursprünglichen entspricht.

  5. Drücke "Abbrechen" wenn Du es Dir doch anders überlegt hast oder "Nimm die Axt" um die Teilung zu beginnen.

    Während der Teilung kann man den Fortschritt des Vorgangs an einem Laufbalken ablesen. Am Ende erhälst Du eine Meldung, wie lang das Programm gebraucht hat und wieviele Teildateien entstanden sind.

Anmerkung: Wenn die Quelldatei z.B. "Kiss_TourJapan.mp3" heißt, werden die Teildateien standardmäßig folgende Namen erhalten:
Kiss_TourJapan.mp3.0
Kiss_TourJapan.mp3.1
..
..
Kiss_TourJapan.mp3.nn

Wenn Du einen anderen Namen als Zieldatei angegeben hast, wird dieser natürlich verwendet. Hast Du z.B. den neuen Namen "MySong.mp3" angegeben, dann werden die Teildateien folgende Namen erhalten:
MySong.mp3.0
MySong.mp3.1
..
..
MySong.mp3.nn

Egal, wie die Teildateien heißen, die zusammengefügte Datei wird wieder den Namen der Originaldatei erhalten: "Kiss_TourJapan.mp3".

Kleben

  1. Drücke "Kleben" und der Standard-Dialog zum Öffen von Dateien erscheint

  2. Wähle die Teildatei mit der Nr.0

    Wenn Du z.B. "Kiss_TourJapan.mp3" in "Kiss_TourJapan.mp3.0, Kiss_TourJapan.mp3.1, Kiss_TourJapan.mp3.2..." geteilt hast, dann wähle "Kiss_TourJapan.mp3.0", welche die einzige Datei sein sollte, die im Fenster angezeigt wird. Diese Datei hat auch ein Symbol, das ein Unterverzeichnis darstellt.

    Drücke dann "Öffnen" und das Fenster "Kleben" erscheint wieder:

  3. Wähle nun eine oder mehrere der folgenden Optionen aus:

    • Quell- = Zielpfad
      Mit dieser Option wir die zusammengefügte Datei in demselben Verzeichnis erstellt, in dem auch die Teile sind.
      Wenn Du die Option nicht gewählt hast, wird ein Fenster erscheinen, in dem Du das Zielverzeichnis auswählen kannst.

    • Quelldatei löschen
      Ist diese Option gewählt, so werden die Teildateien nach dem Zusammenfügen gelöscht.

    • CRC-Prüfung
      Mit dieser Option wir die CRC-Prüfung aktiviert. Das Progamm teilt Dir nach dem Zusammenfügen mit, ob die Zieldatei der ursprünglichen exakt entspricht. Voraussetzung ist natürlich, daß beim Teilen auch die Prüfsumme erstellt wurde!

  4. Drücke "Abbrechen" wenn Du es Dir doch anders überlegt hast oder "Teile zusammenfügen" um fortzufahren.

    Falls bereits eine Datei mit dem Zielnamen existiert wird das Programm Dich fragen, ob die Datei überschrieben werden soll.

    Drückst Du dann "Nein" wird der gesamte Vorgang abgebrochen und Du kommst zurück zum Hauptfenster von Hacha 3.5. Drücke "Ja" wenn Du die Datei überschreiben willst.

    Wenn Du wieder im "Kleben"-Fenster bist, zeigt der Laufbalken den Fortschritt des Zusammenfügens an. Danach bestätigt eine Meldung das Ende des Vorgangs.

Anmerkung: Es gibt Programme, die direkt versuchen, die Teildateien auf Diskette zu speichern. Ich empfehle aber, erst alle Teildateien auf der Festplatte zu erstellen und sie anschließend auf Diskette zu kopieren. Dieser Vorgang ist wesentlich schneller und auch sicherer, da Fehler beim Speichern auf Diskette nicht den Teilvorgang abbrechen und Du wieder komplett von vorn beginnen mußt.

Hacha 3.5 ist Freeware!

Du kannst so viele Kopien von dem Programm erstellen wie Du willst und sie uneingeschränkt (einschließlich dieser Hilfedatei) weitergeben. Du darfst kein Geld mit diesem Programm verdienen!

Hacha 3.5 kann von meiner Homepage www.hacha.org in vielen Sprachen heruntergeladen werden. Ich habe natürlich auch nichts dagegen, wenn Du einen Link auf meine Homepage in Deiner einfügst.

Hacha 3.5 wird geliefert wie es ist. Ich übernehme keine Garantie für die einwandfreie Funktion des Programmes. Du benutzt das Programm auf eigene Verantwortung! Dr. Software übernimmt keine Verantwortung für entstandene Schäden oder Verluste von Daten. Außerdem übernehme ich keine Verantwortung für Schäden, die bei bei der Anwendung, Fehlbedienung oder Missbrauch des Programmes entstehen.

©Dr. Software. Alle Rechte vorbehalten.

Übersetzt von Mila-Christine Langbehn und Markus Lau


"Hacha" (Axe - Ascia - Hache) was created for:
Dr. Software More freeware:
http://www.hacha.org
[ Back ]